Custom fonts stopped working

  • 1
  • Problem
  • Updated 4 years ago
  • Not a Problem
I use custom fonts from my server. I tried to change font size only (not the font path itself) and presentation stopped loading the font. I checked - font is in place and available, I can copy its path from browser when listing files. OS: Win 8.1, browser: latest Chrome 64-bit with DirectWrite disabled.
Tried to test in new presentation and new region - same situation. Even checked with other font locations by putting them on other servers - still the same.
Can anybody confirm and/or help?
Photo of Andrzej Krause

Andrzej Krause

  • 140 Points 100 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Hi Andrej,

Can you let us know what Widget/Gadget you are trying to use the custom font in?  Are you seeing the problems in the editor/preview, or is it on a Display?

Thanks.
Photo of Andrzej Krause

Andrzej Krause

  • 140 Points 100 badge 2x thumb
Sorry, I forgot. RSS.
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Andrzej,

What type of font are you trying to use?  I was having some difficulty with TTFs, but OTFs seemed to work fine.  If it is TTFs, you may want to consider a site like this that converts the fonts to OTF.

Thanks.
Photo of Luke Edlin

Luke Edlin

  • 80 Points 75 badge 2x thumb

Hi, I am new to this, I have no previous experience with html so I freely admit I may be missing something silly. I cannot get custom fonts working either. Using the guide online I entered the following code into the Text Item's html editor.

<style>
  @font-face {
    font-family: brda;
    src: url('http://commondatastorage.googleapis.com/risemedialibrary-XXXXX/brda.o...;
  }
</style>

<p style="font-family:brda;">HELLO WORLD</p>

Obviously the Xs are just there to protect my files. I have tried using both OTF and TTF fonts with no joy.

I am at my wits end, please help!

Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
I've seen some fonts set with a Cross-origin domain restriction.  It is possible this is affecting what you're seeing.  I don't see anything wrong with what you've provided here in the forum.

You can confirm the Cross-Origin message by opening Developer Tools (F12) when Previewing the Presentation and going to the Console tab. You'll see a message similar to this one:
Font from origin 'http://commondatastorage.googleapis.com' has been blocked from loading by Cross-Origin Resource Sharing policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'http://preview.risevision.com' is therefore not allowed access.

Thanks.
Photo of Andrzej Krause

Andrzej Krause

  • 140 Points 100 badge 2x thumb
Yay, that works for me too!
Photo of Luke Edlin

Luke Edlin

  • 80 Points 75 badge 2x thumb
Yes, I see that message, thanks for the quick reply. Is there any fix or workaround for this or am I pretty much screwed?
Photo of Andrzej Krause

Andrzej Krause

  • 140 Points 100 badge 2x thumb
The answer is here:  http://stackoverflow.com/questions/5008944/how-to-add-an-access-control-allow-origin-header (first one, using .htaccess and absolute URLs to font files).
Photo of Luke Edlin

Luke Edlin

  • 80 Points 75 badge 2x thumb
Thanks but I don't know how to do the htaccess part. I need a serious idiots guide, completely new to this. I'm a biochemist, talk to me about protein folding and I'm your guy but digital signage has kind of been thrust upon me unwillingly.
Photo of Techwise

Techwise

  • 762 Points 500 badge 2x thumb
Hi Neal. Is there anything we can do to allow the font to be read from your file storage. Both OTF and TTF fonts are being blocked from http://commondatastorage.googleapis.com. The .htaccess file didn't seem to fix it for me.
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Techwise,

I'm not aware of different methods to overcome Cross Domain policy issues at this time.

Thanks.