Crashes Today

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
Anything funny going on today?  Six of my displays using the new Windows Player are crashing and restarting, crashing and restarting...  Has there been an update to the player?  What is the current version?  Is this out of Beta?
Photo of Tri-C Metro

Tri-C Metro

  • 1,642 Points 1k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Tri-C,

Can you give me the name of one of the displays that is restarting?
Photo of Tri-C Metro

Tri-C Metro

  • 1,642 Points 1k badge 2x thumb
MBA Lobby
Photo of Tri-C Metro

Tri-C Metro

  • 1,642 Points 1k badge 2x thumb
Blake, its more than just my displays with new WIndows Players.  All of them are going in and out.  watchdog is starting up web player and some of the windows players are rebooting but some are not. Looks like only one java process is restarting on those.
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Tri-C,

So you're saying that you have some players with Rise Windows Player, and some with the Rise Player Chrome Extension, and all of them are restarting?
Photo of Tri-C Metro

Tri-C Metro

  • 1,642 Points 1k badge 2x thumb
yes
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Tri-C, definitely sounds like an environmental or content problem. We're not seeing any widespread issues with either player at the moment.

Has your content changed recently? Any network changes? Any changes to your players? Are they running Application Monitor?
Photo of Tri-C Metro

Tri-C Metro

  • 1,642 Points 1k badge 2x thumb
nothing has changed.  this is very weird
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Tri-C,

I would recommend powering down one of the devices, uninstalling the existing Rise Player, and installing Rise Windows Player according to these instructions. I really don't know where to begin with this, since it's two different versions of player, running all sorts of different content and we don't have any known similar issues with either player. 
Photo of Tri-C Metro

Tri-C Metro

  • 1,642 Points 1k badge 2x thumb
is there something besides deleting the RV player folder that i should do before a new isntall
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Tri-C,

Remove it from the startup menu, and remove any instances of Application Monitor that are installed.
Photo of Tri-C Metro

Tri-C Metro

  • 1,642 Points 1k badge 2x thumb
has anyone noticed the new Rise player for Windows not starting on system reboo?  The second java process disappears sometimes and player needs to be re-installed.
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Tri-C,

I haven't noticed that at all. Can you confirm that you do not have any other Rise Players listed in your startup group, and you do not have Application Monitor installed?
Photo of Tri-C Metro

Tri-C Metro

  • 1,642 Points 1k badge 2x thumb
I think the issue has been narrowed down to the new install of the Windows RV player.  i just did a complete uninstall reinstall. Watching the processes in task manager shows both java processes start and then one drops off and the player won't run.  should there be three versions of chrome?:
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Tri-C,

Didn't you mention yesterday that both Rise Windows Player and the Rise Player Chrome App were crashing for you?

Can you please confirm if you are running Application Monitor on any of these devices?
Photo of Tri-C Metro

Tri-C Metro

  • 1,642 Points 1k badge 2x thumb
two separate issues.  the Chrome app player is doing what it always does - crashing.  i figured that yesterday.  now, i am trying to get windows player to work.  is it possible application monitor is hidden somewhere i cant find it?
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Tri-C, unlikely. It's installed under C:\ or C:\Program Files, I would check both of those places.
Photo of Tri-C Metro

Tri-C Metro

  • 1,642 Points 1k badge 2x thumb
Blake, I started fresh on a display.  Gutted everything I could, deleted and added a new display... I reinstalled RV player and it worked perfectly after the install.  I let it run for about twenty minutes.  No crash.  Then, I restarted and RV player would not launch.  Here is something I found in a text document in the RV player folder:

Sep 30 10:53:23.332 INFO: ***** RisePlayer version 2015.09.22.12.50 *****Sep 30 10:53:23.332 INFO: Application properties file is not found. Using default setting. File name: RisePlayer.properties
Sep 30 10:53:23.332 INFO: Loading display properties...
Sep 30 10:55:51.844 INFO: ***** RisePlayer version 2015.09.22.12.50 *****
Sep 30 10:55:51.860 INFO: Application properties file is not found. Using default setting. File name: RisePlayer.properties
Sep 30 10:55:51.860 INFO: Loading display properties...

Sep 30 11:01:16.413 INFO: ***** RisePlayer version 2015.09.22.12.50 *****
Sep 30 11:01:16.428 INFO: Application properties file is not found. Using default setting. File name: RisePlayer.properties
Sep 30 11:01:16.428 INFO: Loading display properties..

These are the last two attempts at starting the RV player.

Thoughts?  I do pay for tech support if I need to bring in the big guns on this...
Photo of Tri-C Metro

Tri-C Metro

  • 1,642 Points 1k badge 2x thumb
The second java process is simply not there either
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Tri-C,

I'd like to get remote access to one of your devices to see what's going on. Could you send a message using the chat bubble on risevision.com's lower right? I'll get you set up with a remote session.
Photo of Tri-C Metro

Tri-C Metro

  • 1,642 Points 1k badge 2x thumb
how are you going to connect?  The original Bomgar was removed by our ITS department upon arrival.   Can you use Windows Remote Desktop?
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Tri-C,

After close review of your machine, it looks like your Proxy is causing the issue. Java does not use Windows/IEs proxy settings by default. We added an environment variable called _JAVA_OPTIONS to provide the proxy information to Rise Player and Rise Cache.
Photo of Tri-C Metro

Tri-C Metro

  • 1,642 Points 1k badge 2x thumb
wow. that was an intense troubleshooting session.  well done.  I will continue to test that display for today and deploy the fix to my other twenty machines when I feel it is stable.  Could you provide me with steps to add the environmental variable please?
And thanks!
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
The variable name is _JAVA_OPTIONS, and the value: -Dhttp.proxyHost=111.111.111.111 -Dhttp.proxyPort=8080 -Dhttps.proxyHost=111.111.111.111 -Dhttps.proxyPort=8080

You will need to replace the 111.111.111.111 and 8080 with your specific proxy information.