Changing the resolution on the Rise Vision player on a Raspberry Pi?

  • 1
  • Question
  • Updated 4 years ago
I have a presentation setup with the resolution of 1920x1080, have my Pi hooked up to a 42'' TV with 1920x1080 resolution, and went to the "Displays" tab and tried to add a display with that same resolution, however it is showing as "Not Installed" and 0x0 resolution.  We initially had this Pi hooked up to a small TV with a 1756x952 resolution, and that is the resolution that is showing on the 1080 TV.  Is there a way to change the resolution of the RV player on the Pi?  

I have minimal experience with the Raspberry Pi and Linux so I'm not sure if I'm overlooking something simple.  I hit Alt+F4 after I rebooted the Pi and looked in the File system, but I didn't see any apps corresponding to RV player or Rise Vision player.  I did navigate to the "Display properties" on the Pi and did see that the screen resolution was set to 1756x952 and when I selected "Auto" and hit save, it automatically reverted back to the oddball resolution when I went back into the setting and a reboot didn't help either.  

I did see a post about navigating to \rvplayer\Risedisplay Network II.ini and inputting the Display ID of the "Display" that I added (the one with a 0x0 res), however I would think that there would be an easier way to accomplish this.  I've also read posts that state that the RV player will default to whatever resolution is native on the display, however its been 2 days and multiple reboots.

Any help would be appreciated.

Thanks
Photo of Dan Hoffman

Dan Hoffman

  • 362 Points 250 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Dan,

The first step will be getting the Pi to display on 1920x1080. Have you been able to change the OS resolution successfully outside of RV Player?

Next would be to change the display ID of your player to use the presentation that's set up as 1920x1080. I would handle the general resolution first.
Photo of Dan Hoffman

Dan Hoffman

  • 362 Points 250 badge 2x thumb
The display properties on the Pi are set to 1756x952, which is the exact resolution of the 1st "Display" that was added by my boss from the "Displays" tab in Rise Vision.  It seems that the Pi is still getting its display settings from the initial display that was setup, since I haven't seen that resolution on any other display in my life, so I'm rather sure that the Pi wouldn't default to such a strange resolution.  I'm just not sure how to get the new "Display" that I added in Rise Vision to be the default, or if I'm able to edit the resolution in the RV player itself.
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Dan,

Can you set the display properties on the Pi to 1920x1080, then change the display ID in the \rvplayer\Risedisplay Network II.ini file to the display assigned to the properly sized presentation?
Photo of Dan Hoffman

Dan Hoffman

  • 362 Points 250 badge 2x thumb
OK, good news is I got the Pi to display 1920x1080 by inputting the display ID for the 1920x1080 "Display" that I created, and overscan is disabled per your guide for the Raspberry Pi Optimization settings.  The problem I'm running into now is the desktop & presentation are a bit too large for the display, so I attempted to adjust the overscan settings per the guide.  I have tried a bunch of different numbers, however none of the adjustments I'm typing into the terminal seem to apply, after every reboot the screen looks exactly as it has before.  My defaults were
overscan_left=16
overscan_right=16
overscan_top=16
overscan_bottom=16

I have tried:
left=50, right=50, top=20, bottom=20 
left=75, right=75, top=30, bottom=30
left=100, right=100, top=20, bottom=20

I have made sure to save each time before a reboot, and I know the settings are saved, as the next time I would type sudo nano /boot/config.txt, it would reflect the numbers that I just input.  Any recommendations for this issue?
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Could it be the display itself needing calibration?
Photo of Dan Hoffman

Dan Hoffman

  • 362 Points 250 badge 2x thumb
Shouldn't the overscan settings being changed have some impact visually though?  I'm not seeing any change at all, whether top=100 or top=16 for example.
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Dan,

I assume this is the documentation that you have already seen. If so, can you please check this article and under advanced options read the overscan section?

When you change the overscan values, have you uncommented the lines in use? Have you tried disabling overscan completely?
(Edited)
Photo of Dan Hoffman

Dan Hoffman

  • 362 Points 250 badge 2x thumb
I'm going to try a few different things that you mentioned this afternoon, and I'll get back to you with the results, thanks for all the help you have provided thus far!
Photo of Dan Hoffman

Dan Hoffman

  • 362 Points 250 badge 2x thumb
The solution to my issue was that I needed to change the framebuffer values in the /boot/config.txt settings.  I uncommented out the values that were in there and input 1920x1080.  I have disabled overscan and used the 50/50/20/20 settings and the display properties for the Pi then showed 1920x1080 on reboot.
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Thanks for the information. Good to hear you have it showing the correct resolution.