android video widget display a blackscreen

  • 1
  • Question
  • Updated 1 year ago
  • Acknowledged
Hi All,
My player is a Philips monitor with Android 4.4.4. My presentation is working fine except my webm videos...
Here is my presentation : http://preview.risevision.com/?type=presentation&id=d5006946-ea5e-4ec0-a5b4-afe3ece27c53

I should miss something but I can't see it..
Thank you in advance for your help
Photo of Philippe Reaud

Philippe Reaud

  • 772 Points 500 badge 2x thumb

Posted 1 year ago

  • 1
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb
Try MP4 because Webm might not work on that version of andrioid. Also be sure your using the android html5 widget.
Photo of Mike Thomas

Mike Thomas

  • 1,282 Points 1k badge 2x thumb
Hello Philippe,

Thanks for posting on our community! Have you been able to recreate this playback problem with a .MP4 video file?

Let us know!

Regards,
Mike Thomas
Rise Vision Support
Photo of Philippe Reaud

Philippe Reaud

  • 772 Points 500 badge 2x thumb
Dear Mike and William, It's working fine with the MP4 file !
The "PUD" option does not work properly. When I choose the PUD option, I can see the message " Please wait, your video is downloading to cache" during 10 seconds and after blackscreen. When I set the time playback according to my video (40 sec), the message still on the screen until the video start. And it's working fine...
All the best.
Philippe
Photo of Philippe Reaud

Philippe Reaud

  • 772 Points 500 badge 2x thumb
Dear All. After testing during hours, I remark that the video mp4 is playing well for 1 hour.. after that it plays a black screen during the time of the video... I restart the player and the video is playing again for an hour..,
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb
In the android settings there should be a setting to change webviews. This will load a newer version of webview than the one thats on the device. See if that changes anything. Now i will let you know that android 4.4.4 and lower will be not supported in the future. We havent decided on a date but we are going to require 5.0 and above for our app. This might happen next year. The reason has to do with webview. Android 4.4.4 and below the device webview doesnt get update unless you use a webview library like we do. Only issue is the project we were using has been discontinued. In android 5.0 and above webview gets updated through the Play Store. 

Anyway try changing the webview setting in the app and see if the video plays any better.

Thanks