AccessDenied

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
Hello all,

I'm new to the platform but have been making progress. Recently, I added my first display with a schedule that played content from Rise Storage. It worked great. 

However, now when my display tries to load my presentation I get the message, "AccessDeniedAccess denied." (written exactly like that.) I've deleted and re-added the display, deleted and re-created the schedule and have always had the schedule set to All Displays.

I'm puzzled. Anyone? (display: Chrome, Rise Player)

Thanks,
matt
Photo of Selch

Selch

  • 90 Points 75 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Hi Selch, this doesn't sound familiar to me.  Could you please send a link to your presentation in case it is related to that?  

Also, when you say that your display is Chrome, do you mean a Chromebox?
Photo of Selch

Selch

  • 90 Points 75 badge 2x thumb
I mean the player in the Chrome browser. 

I tracked it down to a 403 thrown on the directory that I uploaded to Rise Storage and am using in my schedule (using Chrome's dev tools to see the error.)

I have two accounts with Rise and have had issues with the cookies you guys set when I log into the site. Since you're constantly spawning tabs and logging us in, I think my cookies somehow got crossed and my upload to Rise Storage was from one account and went into the other. (I worked 5 years BestBuy.com DevOps, I saw this kind of stuff all the time.)

That's my theory.

I don't have a link for you as I've been adding and deleting things trying to troubleshoot. I do have a request in to customer service to kill one of my accounts. Then at least I can start over clean.

Other ideas?
Photo of Selch

Selch

  • 90 Points 75 badge 2x thumb
I'm back in business. Logged out of Rise. Deleted all cookies and cache in Chrome and logged back in. Deleted offending directory and re-uploaded local folder to Rise Storage and now all is well.
(Edited)
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Hi Selch, good troubleshooting and I am glad you found and corrected the issue.  Thanks for the update.