A new version of the Web Page Widget is now available!

  • 4
  • Announcement
  • Updated 2 years ago
We just released a new version of the Web Page Widget that includes improvements I'm sure everyone will appreciate!

When you enter the URL to a Web Page in the settings, we'll let you know if it can't be embedded due to the pages x-frame-options.


We've also improved the Widget by creating a seamless refresh that eliminates visible page reloads.

And last, you'll notice a new checkbox called, "Unload Web Page when not visible in the Presentation".


This gives you more control over how the Widget will behave when rotating with other Content items in a Playlist. By default, we'll unload the Web Page to prevent resources on the page from running (e.g., audio), but if you want to keep those resources running, or if you want to eliminate the Web Page loading on each Playlist rotation, simply uncheck the option and your Web Page will always be running and available in the background!

As always, let us know your feedback or if you run into any issues.

Photo of Alan Clayton

Alan Clayton, Official Rep

  • 8,788 Points 5k badge 2x thumb

Posted 3 years ago

  • 4
Photo of FIAS IT


  • 670 Points 500 badge 2x thumb
Thank you, Thank you.
this seems to have solved my issue with google slide presentations in a web page widget reloading each time a schedule changes presentation
Just unticked the box and everything seems good on a quick test.
Photo of Alan Clayton

Alan Clayton, Official Rep

  • 8,788 Points 5k badge 2x thumb
Thanks for the feedback!
Photo of Robert Schoneman

Robert Schoneman, Champion

  • 4,990 Points 4k badge 2x thumb
Nice work on the new Web Page Widget! The option to unload the page is a nice addition along with the refresh intervals. Thanks! 
Photo of XMedia Dubai

XMedia Dubai

  • 2,786 Points 2k badge 2x thumb

Facing an issue, i am trying to run streaming audio embedded as html page. Now when i run it through web page widget with visible option 'checked' and unload web page option 'unchecked' the audio is working. But if i uncheck the visible option and hide the placeholder, the audio doesnt work.

Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb

This is because since the Placeholder is not visible, it is not being loaded, and therefore no content in it is not being loaded. A better option if you want to hear the audio would be to make the Placeholder 1x1 pixels, and put it in a corner of the Presentation.

This way you can hear the audio, always access the Placeholder in the list of Placeholders, and it won't show in your Presentation. Unless you look really really REALLY closely :)

Let me know if that will work for you.