A new version of the Video Widget has been released!

  • 7
  • Announcement
  • Updated 3 years ago
Previous to this release we only stored videos in Rise Cache if they were hosted on Rise Storage. With this update the Video Widget will now cache all Videos regardless of where they are hosted. 

As always, let us know your feedback or if you encounter any issues.

Enjoy! 
Photo of Alan Clayton

Alan Clayton, Official Rep

  • 8,788 Points 5k badge 2x thumb
  • Happy

Posted 3 years ago

  • 7
Photo of Sanjay Kaler

Sanjay Kaler

  • 1,472 Points 1k badge 2x thumb
Excellent, much needed update :-)
Photo of Nathan Cummins

Nathan Cummins

  • 662 Points 500 badge 2x thumb
Good news! I'll be spending the day upgrading my presentations to the new widget!
Photo of Thierry Masson

Thierry Masson, Champion

  • 2,356 Points 2k badge 2x thumb
Fantastic. Thanks so much ....
Photo of Thierry Masson

Thierry Masson

  • 922 Points 500 badge 2x thumb
HI,
I've tested it this afternoon. I was using a Chrome box on Chrome OS 46 (46.0.2490.71 and RisePlayerPackagedApp 15.10.7.9312).

This sounds to work  well. I created a page with a placeholder and a set of video gadget using videos stored externally. To be sure, I waited the full first cycle of video to be played and after, I unplugged the network cable. RiseVision continued to work perfectly well  playing all videos in a raw. This was not the case before.

Some comments anyway :
  • Does the cache apply across ChromeOS reboots ?
    I've a doubt because after a reboot and Rise started, I unplugged the network cable and the videos did not play. I got the Chrome OS dinosaur icon displayed instead.
  • THe first time the video loads, I got a message 'Video downloading' or similar and after I got a black placeholder for the video (but all other gadget on the screen were OK) and I had to wait several minutes before getting the video played.
Thanks.
Thierry
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Thierry,

Rise Player still requires an initial connection to the internet after a reboot in order to connect and get your display information. 
The video downloading message is intended. It's a placeholder to let you know why there is no video playing at the time. Once it's fully downloaded, it will begin play.
Photo of Thierry Masson

Thierry Masson, Champion

  • 2,356 Points 2k badge 2x thumb
Maybe I unplugged the newtork cable a bit too early. I will try again.

It would it be great to allow the RiseVision client booting even without an Internet connection because a short disruption may occur from time to time. The client would use the latest settings it got with maybe for those who care about a maximum expiration time. Once the connection is re-establish, the RiseClient could update from the server. This would be great.

On ChromeOS, when an Internet link is not available for sometimes (if I remember well), the RiseVision has a timeout and the only way to make a new attempt is to reboot the ChromeOS. With a managed Google domain, it is not difficult to do remotely once the newtork is back but otherwise, a power on/off is required. 


Thanks.
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Thierry,

I agree, offline functionality for Rise Player would be good. Thanks for the idea!
Photo of AdGators AdGators

AdGators AdGators

  • 3,612 Points 3k badge 2x thumb
Tested locally and glad to report this is working quite well!
Thank you!
Photo of Thierry Masson

Thierry Masson

  • 922 Points 500 badge 2x thumb
Question on new video gadget and caching ....

The first time I boot a new page, it may take several minutes to get the first video played. Furthermore, after reboot, it takes at least one minute to start playing.

My questions :
- If in one page I've a set of video gadget in a stack playing from the same placeholder, must all videos be loaded before the first one start to play ?
- Why does it take around one minute (in my case) before a video start to play after a reboot ?

Many thanks again for this new gadget. 
Photo of Alan Clayton

Alan Clayton, Official Rep

  • 8,788 Points 5k badge 2x thumb
Until the video is downloaded into Rise Cache you'll see a message that the video is downloading. How long you see this message will depend on file size and bandwidth.

As for taking one minute for the video to show after a reboot. What do you see in the Placeholder during that one minute prior to the video showing?
Photo of Thierry Masson

Thierry Masson

  • 922 Points 500 badge 2x thumb
Thanks replying.First, I see a message 'Wait while your video is downloaded' or similar.
Then, the placeholder becomes black and I've to wait more than 1 minutes to get the first video playing. I will check with a network analyzer to see if there is a network activity during this time.
Best regards.
Thierry
Photo of Thierry Masson

Thierry Masson

  • 922 Points 500 badge 2x thumb
It is OK now. I explained in another post issues I got with network issues. Maybe it was linked.
I've reinstalled the Chromebox from a USB key (Chrome 45) and installed the lastest RieVsion player (the brand new one). Now, after a few cycle in the playlist, I've rebooted the Chromebox. 
I got the 'Wait while the videos are downloaded' for no more than 4 seconds. Then, a black window for 3 seconds and videos get played.
This is excellent.
Best regards.